Default Theme gettext-Edition

Seit Version 2.6 ist das Default Theme von WordPress mehrsprachig. Das Theme, das ich hier vorstelle, ist nur noch für Versionen unter 2.6 sinnvoll einzusetzen.

 

Wenn WordPress mehrsprachig verwendet werden soll, muss das Theme gettexted sein.

Da das Standard Theme von WordPress nicht mehr in der gettext-Version angeboten wird, biete ich meine Version hier zum Download an. Durch die Umstellung dieser Webseite auf WordPress und den Wunsch, die Seite auf deutsch und englisch gestalten zu können, musste ich mir eh die Arbeit machen, das Theme zu gettexten.

  WordPress Default gettext-Edition 1.0 (54,4 KiB, 2.195 Hits)

Die deutsche Sprachdatei ist mit dabei, das Theme beinhaltet also Englisch und Deutsch. Gerne nehme ich andere Sprachen mit in das Theme auf, deswegen liegt eine passende .pot-Datei bei.

Wenn nicht nur das Theme sondern auch der Inhalt der Beiträge und Seite (optional) mehrsprachig sein soll, empfielt sich das WordPress-Plugin Polyglot. Für die deutsche Sprache muss hier zusätzlich eine Datei namens de.mo mit dem Inhalt der Datei de_DE.mo im Theme-Verzeichnis angelegt werden (ein Symlink geht natürlich auch) da die Locale bei Polyglot nicht de_DE heisst sondern nur de. Bei anderen Sprachen tritt dieser Effekt natürlich auch auf.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.